arm port · Odd Fixes
Maintainers
- M Russell King <linux@armlinux.org.uk>
Paths
- F
arch/arm/ - X
arch/arm/boot/dts/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-block (capped at 30), ordered by date desc.
-
COLD17d
[PATCH 04/19] arm: define DPS root partition type UUID
2026-06-15 · Vincent Mailhol <mailhol@kernel.org> -
STALE79d
[PATCH 34/61] arch/arm: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE201d
[PATCH v4 1/3] init: remove deprecated "load_ramdisk" and "prompt_ramdisk" command line parameters
2025-11-19 · Askar Safin <hidden> -
STALE255d
[PATCH v3 1/3] init: remove deprecated "load_ramdisk" and "prompt_ramdisk" command line parameters
2025-10-17 · Askar Safin <hidden> -
STALE264d
[PATCH v2 1/3] init: remove deprecated "load_ramdisk" and "prompt_ramdisk" command line parameters
2025-10-10 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 61/62] init: rename CONFIG_RD_LZ4 to CONFIG_INITRAMFS_DECOMPRESS_LZ4
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 59/62] init: rename CONFIG_RD_XZ to CONFIG_INITRAMFS_DECOMPRESS_XZ
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 54/62] init: arm, x86: deal with some references to initrd
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 41/62] init: rename reserve_initrd_mem to reserve_initramfs_mem
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 40/62] init: rename free_initrd_mem to free_initramfs_mem
2025-09-14 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 19/62] init: remove mentions of "ramdisk=" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 16/62] brd: remove "ramdisk_size" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 11/62] init, efi: remove "noinitrd" command line parameter
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 08/62] arm: init: remove FLAG_RDLOAD and FLAG_RDPROMPT
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 07/62] arm: init: remove ATAG_RAMDISK
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 06/62] arm: init: remove special logic for setting brd.rd_size
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 04/62] init: x86, arm, sh, sparc: remove variable rd_image_start, which controls starting block number of initrd
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 02/62] init: remove deprecated "prompt_ramdisk" command line parameter, which does nothing
2025-09-13 · Askar Safin <hidden> -
STALE268d
[PATCH RESEND 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
2025-09-13 · Askar Safin <hidden> -
STALE272d
[PATCH 02/62] init: remove deprecated "prompt_ramdisk" command line parameter, which does nothing
2025-09-12 · Askar Safin <hidden> -
STALE272d
[PATCH 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
2025-09-12 · Askar Safin <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE79d
[PATCH 34/61] arch/arm: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>